User:Chris Burke/Export Script

From J Wiki
Jump to: navigation, search

Note: work in progress. This requires the latest scripts.

Export Script converts a script into html format. It is an update of the HTML Publish and scriptdoc systems in J601 and earlier.

Export Script can be run from the session menu, Project Manager menu, or with a session command.

Menu

Menu Edit|Export Script is enabled when a script window is active. Selecting this menu creates html file jpath '~temp/export.htm' and launches it in the browser.

To configure the export, hold down the shift key when selecting the Export Script menu. This brings up the Export Script dialog, where you can set various options and color schemes. Windows users can also output to an OCX control; this can be useful for experimenting with preferences.

Project Manager menu Tools|Export Script has the same behaviour.

To configure the browser, select menu Edit|Configure...|External Programs.

Command

Load Export Script with command:

load 'export'

This populates locale jexport. Main definitions:

export runs the Export Script dialog, with an optional script name. This corresponds to selecting the Export Script menu with the shift key held down. For example:

export_jexport_ '~system/main/dates.ijs'

exports runs the export and launches the browser. This corresponds to selecting the Export Script menu. For example:

exports_jexport_ '~system/main/dates.ijs'

exportrun runs the export. The argument has the source script, and optionally, the target file and color scheme. This can be used to run the export on several files under program control. For example:

exportrun_jexport_ '~system/main/dates.ijs';'~temp/dates.htm';'Emacs'