J6/Project Manager/Overview

From J Wiki
Jump to: navigation, search
J6/Project Manager | Overview | Build | Links | Project File | Snapshots | SVN | Tabs


Project Manager lets you work with applications that are built from several scripts. You can specify scripts to be included in the application, scripts required for development purposes only, and how the application is to be built.

The scripts are maintained individually during development, and can be compiled into a single output script for distribution/runtime/installation purposes. You can customize the build to suit your applications.

Project files distinguish between scripts you write specifically for the project, and library scripts distributed with the system that are needed by the project. The project build can automatically includes required library scripts.

Typically all the files in a project, apart from library files, will be stored in a single directory, for example, a subdirectory of user\projects. Within the directory will be a project file, plus the project source scripts.

Project Manager Dialog

Run the Project Manager from menu Edit|Project Manager... or by pressing Ctrl-B.

In the Project Manager dialog, open a project file by either:

  • selecting from the Project list
  • running menu File|New...
  • running menu File|Recent...

The Project list shows all files with extension .ijp found in the Look In folder and its subfolders. If the project filename is the same as its folder name, for example, mygraph\mygraph.ijp, then only the filename is shown.

Project Manager works with the folder names defined in Edit|Configure|Folders. If you create a project in one of these folders, Project Manager automatically uses the folder name when storing file names. This makes it easy to move or distribute your project - you need only define the folder name appropriately.

You should set Look In to point to the folders (directories) where you are creating J projects. For example, the default Look In folder is user\projects. You might then create projects in directories such as user\projects\work, user\projects\test etc.

You can define and modify the Look In folders by selecting menu Options|Look In Folders.

When the Look In folder has more than one level, you can move up or down levels by pressing the arrow buttons to the right of the Look In folder control.

The menu File|Recent... shows the last 20 projects that have been loaded.

When a project is open, use Load to load the project on top of existing definitions.

Use menu Project|Build Options... to specify how the application is to be built. Use menu Project|Build Application to build the application.

Project Conventions

Project Manager requires that file extensions are ijs for scripts, and ijp for project files.

There are no requirements as to project directories. However, it makes for easier searching if you group the project subdirectories in a small number of directories. For example, you could use the directory user\projects, and you might then create subdirectories such as user\projects\mywork, user\projects\utils etc. Also, you may wish to name project files with the same name as the directory, since this simplifies the display in the Look In list box.

For applications where there are several developers, it is probably better to avoid the default J directories altogether, and create new directories for each application. This makes it easier to share code between the developers.

Since directories are searched for project files when you use the Project Manager, you should avoid using directories where there are a large number of subdirectories not being used for projects. For example, you would typically not include any projects under the J system subdirectory.

Project Notes

The Notes editbox in menu File|Notes is for free-form comments. These comments are stored in the project file only, and do not appear in the final application.